It is currently Fri Aug 23, 2019 4:25 am

All times are UTC




Post new topic Reply to topic  [ 159 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10, 11  Next
Author Message
PostPosted: Mon Jan 29, 2018 9:33 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
Got the batch file ready and working, now all I need is a bash script to run the wine cmd terminal from within playonlinux, which I have posted on their forums for. thanks a lot for your help!

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 29, 2018 9:39 pm 
Offline

Joined: Tue Jan 11, 2011 9:26 pm
Posts: 2460
Location: Ontario, Canada
I think you will need to post on the PlayOnLinux forum, not the Wine one but you will find out soon enough.

_________________
-------------------
-Jamie Marchant
If I don't respond it's because email notification is down again and
I forgot to return to the thread.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 29, 2018 10:20 pm 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1259
Location: Central Europe
OP here; I’m following, but I don’t have much to add :) because I currently only have Linux in a VM without access to the graphic card, so not the best gaming experience :lol:

I did a quick test with Wine 3.0 alone, and it seems able to run all the main shards (Cyan, Minkata, Gehn, TOC) with some tinkering (I’ve run “winetricks vcrun2015 d3dx10” and installed the PhysX version that came with Minkata). The chat seems to work for me, so I have no suggestion to offer.

I made a few scripts for PlayOnLinux, which could use some more testing and tweaking, if you’d like.

There’s also a Uru Live page in the WineHQ AppDB, I’ve just asked to be the maintainer.

_________________
KI #46116. Donate to help the Cavern stay open!
Want to know what’s going on in the Cavern? Visit the GoMe site.

MacOS wrappers, D’ni Lessons, DniTools, goodies.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 29, 2018 10:25 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
korovev wrote:
OP here; I’m following, but I don’t have much to add :) because I currently only have Linux in a VM without access to the graphic card, so not the best gaming experience :lol:

I did a quick test with Wine 3.0 alone, and it seems able to run all the main shards (Cyan, Minkata, Gehn, TOC) with some tinkering (I’ve run “winetricks vcrun2015 d3dx10” and installed the PhysX version that came with Minkata). The chat seems to work for me, so I have no suggestion to offer.

I made a few scripts for PlayOnLinux, which could use some more testing and tweaking, if you’d like.

There’s also a Uru Live page in the WineHQ AppDB, I’ve just asked to be the maintainer.


Thanks a million, that's great! I don't really do shards though, I'm afraid :).

Just to add, it turns out I have another issue, which only occurs if I have been playing for a while. Game crashes with prompt and code

Code:
 UruLive.Live.1.918.OpenUru=138 - External.Release
Exception type: Access violation
Call stack (14 levels):
 0x00000000
  0x00000000
   0x00000000
    0x00000000
     0x00000000
      0x00000000
       0x00000000
        0x00000000
         0x00000000
          0x00000000
           0x00000000
            0x00000000
             0x00000000
              0xF746FF31

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 7:35 am 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1259
Location: Central Europe
Unfortunately stack dumps aren’t generally useful. On PlayOnLinux you can run the game in debug mode (select Moula and click Debug in the sidebar); that might give some more clues as to the cause of the crash.

_________________
KI #46116. Donate to help the Cavern stay open!
Want to know what’s going on in the Cavern? Visit the GoMe site.

MacOS wrappers, D’ni Lessons, DniTools, goodies.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 9:50 am 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1259
Location: Central Europe
Narameh wrote:
I don't really do shards though

As I’ve mentioned before: if I don’t get any feedback, I can only assume my scripts work and move on to other projects ;) .

_________________
KI #46116. Donate to help the Cavern stay open!
Want to know what’s going on in the Cavern? Visit the GoMe site.

MacOS wrappers, D’ni Lessons, DniTools, goodies.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 11:50 am 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
korovev wrote:
Narameh wrote:
I don't really do shards though

As I’ve mentioned before: if I don’t get any feedback, I can only assume my scripts work and move on to other projects ;) .


That's fair enough! I will see if I can find some time to playtest for you :). Please note though, although I know a tiny bit about what I am doing, I am by no means a computer scientist of hacker, and all I know is home-taught with trial, error and the internet, so bear with me if I miss things or don't know how to do stuff.

korovev wrote:
Unfortunately stack dumps aren’t generally useful. On PlayOnLinux you can run the game in debug mode (select Moula and click Debug in the sidebar); that might give some more clues as to the cause of the crash.


Okay, I have done this thing. Please note, I cannot run debug AND my workaround at the same time, so this log might also have clues about my keyboard issue. It definitely does give keyboard related errors! Also please note: I played until I crashed, but this time did not get the stack dump pop-up, just a plain crash. Here's the debug log:

Code:
[01/30/18 11:21:07] - Running wine-3.0-rc6 UruExplorer.exe (Working directory : /home/narameh/.PlayOnLinux/wineprefix/UruLive_x64/drive_c/Program Files (x86)/Uru Live)
0032:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0032:fixme:winhttp:set_cookies unhandled attribute L"expires"
0032:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0050:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0050:fixme:winhttp:set_cookies unhandled attribute L"expires"
0050:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
URUPlayer StartProc, running game process at dir:C:\Program Files (x86)\Uru Live\, cmd:C:\Program Files (x86)\Uru Live\UruExplorer.exe  for application:UruExplorer.exe
00017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0043:fixme:win:EnumDisplayDevicesW ((null),0,0x33cf08,0x00000000), stub!
0043:fixme:win:EnumDisplayDevicesW ((null),0,0x33d688,0x00000000), stub!
0043:fixme:win:EnumDisplayDevicesW ((null),0,0x33d698,0x00000000), stub!
0043:fixme:win:EnumDisplayDevicesW ((null),0,0x33db08,0x00000000), stub!
0043:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
0043:fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x8090809, 0000: semi-stub!
0043:fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x8090809, 0000: semi-stub!
XIO:  fatal IO error 1 (Operation not permitted) on X server ":0.0"
      after 90901 requests (90896 known processed) with 2 events remaining.


EDIT:
Turns out log for yesterdays sessions *with* workaround were automatically saved as well, even though I was not specifically running in debug mode. Here's the last one:

Code:
[01/29/18 22:26:57] - Running wine-3.0-rc6 wineconsole cmd (Working directory : /usr/share/playonlinux/python)
0035:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0035:fixme:winhttp:set_cookies unhandled attribute L"expires"
0035:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0052:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0052:fixme:winhttp:set_cookies unhandled attribute L"expires"
0052:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0046:fixme:win:EnumDisplayDevicesW ((null),0,0x33cf08,0x00000000), stub!
0046:fixme:win:EnumDisplayDevicesW ((null),0,0x33d688,0x00000000), stub!
0046:fixme:win:EnumDisplayDevicesW ((null),0,0x33d698,0x00000000), stub!
0046:fixme:win:EnumDisplayDevicesW ((null),0,0x33db08,0x00000000), stub!
0046:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
0046:err:d3d:wined3d_debug_callback 0x1f02e8: "GL_OUT_OF_MEMORY in glTexSubImage".
0046:fixme:ntdll:FILE_GetNtStatus Converting errno 12 to STATUS_UNSUCCESSFUL
0046:err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x54027b
0071:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0071:fixme:winhttp:set_cookies unhandled attribute L"expires"
0071:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
008f:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
008f:fixme:winhttp:set_cookies unhandled attribute L"expires"
008f:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0082:fixme:win:EnumDisplayDevicesW ((null),0,0x33cf08,0x00000000), stub!
0082:fixme:win:EnumDisplayDevicesW ((null),0,0x33d688,0x00000000), stub!
0082:fixme:win:EnumDisplayDevicesW ((null),0,0x33d698,0x00000000), stub!
0082:fixme:win:EnumDisplayDevicesW ((null),0,0x33db08,0x00000000), stub!
0082:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
0082:err:d3d:wined3d_debug_callback 0x1f05e8: "GL_OUT_OF_MEMORY in glMapBufferRange(map failed)".


I guess this means it is an opengl issue...?

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 4:09 pm 
Offline

Joined: Tue Jan 11, 2011 9:26 pm
Posts: 2460
Location: Ontario, Canada
Did you open your Ki at the time? I had a graphics issue(but not crash) when doing that. Different video cards could dell with an OpenGL error in different ways.

_________________
-------------------
-Jamie Marchant
If I don't respond it's because email notification is down again and
I forgot to return to the thread.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 4:11 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
Jamie Marchant wrote:
Did you open your Ki at the time? I had a graphics issue(but not crash) when doing that. Different video cards could dell with an OpenGL error in different ways.


I don't think so. I mainly seem to crash on linking or mid-link, although not 100% of the time.

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 4:24 pm 
Offline

Joined: Tue Jan 11, 2011 9:26 pm
Posts: 2460
Location: Ontario, Canada
Ah, I see. What video card do you have and what drivers do you use for it?

_________________
-------------------
-Jamie Marchant
If I don't respond it's because email notification is down again and
I forgot to return to the thread.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 8:23 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
Jamie Marchant wrote:
Ah, I see. What video card do you have and what drivers do you use for it?


Code:
[email protected]:~$ sudo lshw -c video
[sudo] password for xxx:
  *-display               
       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: [email protected]:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f6000000-f6ffffff memory:d0000000-dfffffff ioport:f000(size=64)


Running on Intel HD Graphics 5500 only. Technically, I have a dedicated card (AMD Radeon R7 M270 4GB DDR3) in addition to the intel card, but hybrid graphics/that card only is not supported, or at least I could not get it to play nice. I ended up with a load of graphical glitches and a work-specific program develloped in house would no longer run. I need this program daily, so I stuck with the onboard card only.

More detailed laptop specs:
Model:Dell Inspiron 15 7548
OS 1: Xubuntu 16.04.3 LTS
OS2: Windows 10 (partition to be deleted shortly)
CPU: 5th Generation Intel® Core™ i7-5500U Processor (4M Cache, up to 3.00 GHz)
RAM: 16GB Dual Channel DDR3L 1600MHz (8GBx2)
GPU1: Intel HD Graphics 5500 (in use)
GPU2: AMD Radeon R7 M270 4GB DDR3
HDD: 1TB 5.4k HDD [1TB 5400 rpm SATA Hard Drive]

Only other thing of note in terms of Graphics is that I have a 4K touchscreen. While gaming I set resolution to HD (1920x1080) on desktop, and this is usually fine. At work I frequently switch to full 4K, as having more data on my screen is particularly useful and this is one of the main reasons I went with this model.

Let me know if you need anything more.

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 9:12 pm 
Offline

Joined: Tue Jan 11, 2011 9:26 pm
Posts: 2460
Location: Ontario, Canada
Are you using the intel driver: https://www.intel.com/content/www/us/en ... ivers.html, that might help? (just a guess)

Also is the video card that you are not using doing anything? Make sure it's not interfering. Maybe try removing it just to see if the problem goes away.(though I personally don't think it will make a difference)

_________________
-------------------
-Jamie Marchant
If I don't respond it's because email notification is down again and
I forgot to return to the thread.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 11:33 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
Well I managed to completely screw myself over. Please send help. I thought it might be a good opportunity to try and switch graphics cards, using these steps: https://help.ubuntu.com/community/HybridGraphics. That did not work (black screen after swa). I tried installing some other drivers (https://launchpad.net/~oibaf/+archive/u ... cs-drivers) but that did nothing, so I reverted to the previous ones. Then I ended up with some very odd dependency issues concerning wine, so I uninstalled wine and playonlinux, then reinstalled play on linux and tried to reinstall MOULa, but no, I can no longer even finish the installation process, because I get a stack dump as soon as I hit log in. I get the starting URU splash screen, and the stack dump, and it hangs from there. Again, please help, as I am in way too deep now.

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 11:43 pm 
Offline

Joined: Tue Jan 11, 2011 9:26 pm
Posts: 2460
Location: Ontario, Canada
All I can think of seeing what it says in a terminal again.

_________________
-------------------
-Jamie Marchant
If I don't respond it's because email notification is down again and
I forgot to return to the thread.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 30, 2018 11:57 pm 
Offline

Joined: Sun Mar 29, 2009 4:47 pm
Posts: 230
Location: Oxford, United Kingdom
Jamie Marchant wrote:
All I can think of seeing what it says in a terminal again.


Well, I can't finish the installation, because this happens before the first start:

Code:
UruLive.Live.1.918.OpenUru=138 - External.Release
Exception type: Access violation
Call stack (14 levels):
 0x00000000
  0x00000000
   0x00000000
    0x00000000
     0x7B461ABA
      0x7B4633B2
       0x7B461AAC
        0x0089F598
         0x00464573
          0x00462DFA
           0x00461CC0
            0x004552C3
             0x00451EE7
              0xF748836A


However, I am runnning playonlinux from terminal, and output there says:

Code:
[main] Message: PlayOnLinux (4.2.10) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/narameh/.PlayOnLinux/
[main] Message: Filesystem is compatible
[update_check] Message: List is up to date
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[POL_SetupWindow_Init] Message: Creating new window for pid 5937
[POL_SetupWindow_Close] Message: Closing window for pid 5937
[POL_Config_Write] Message: Config write: MANUAL_INSTALL_INCREMENT 10
[POL_SetupWindow_Init] Message: Creating new window for pid 5937
[POL_SetupWindow_menu] Message: menu answer: Edit or update an existing application
[POL_Wine_SelectPrefix] Message: Selecting prefix: UruLive_x64
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_SetupWindow_checkbox_list] Message: checkbox_list answer: Configure Wine
[POL_SetupWindow_menu_num] Message: menu_num answer: 1
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_Wine] Message: Running wine- winecfg (Working directory : /home/narameh/.PlayOnLinux/wineprefix/UruLive_x64)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
002e:fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
002e:fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
[POL_Wine] Message: Wine return: 0
ls: cannot access '/media/narameh/*': No such file or directory
[main] Message: Autorun : Checking *...
[main] Message: Autorun: Found 0 media
[POL_SetupWindow_browse] Message: browser answer: /home/narameh/Downloads/MOULInstaller.exe
[POL_System_CheckFS] Message: Checking filesystem for /home/narameh/Downloads/MOULInstaller.exe
[POL_Wine] Message: Running wine- /home/narameh/Downloads/MOULInstaller.exe (Working directory : /)
0009:fixme:shell:SHAutoComplete stub
[POL_Wine] Message: Wine return: 0
0038:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0038:fixme:winhttp:set_cookies unhandled attribute L"expires"
0038:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
URUPlayer StartProc, running game process at dir:C:\Program Files (x86)\Uru Live\, cmd:C:\Program Files (x86)\Uru Live\UruExplorer.exe  for application:UruExplorer.exe
00017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0057:fixme:winhttp:set_cookies unhandled attribute L"HttpOnly"
0057:fixme:winhttp:set_cookies unhandled attribute L"expires"
0057:fixme:winhttp:set_cookies unhandled attribute L"Max-Age"
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
004a:err:wgl:init_opengl Failed to load libGL: libGL.so.1: cannot open shared object file: No such file or directory
004a:err:wgl:init_opengl OpenGL support is disabled.


Apparantly openGL support is now disabled? I am going to look into how to fix this, any tips welcome

_________________
KI 07286372

"All things are subject to interpretation whichever interpretation prevails at a given time is a function of power and not truth." - Nietzsche


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 159 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10, 11  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron